Back to overview
Downtime
Systems impacted by global AWS outage
Oct 20 at 09:22am CEST
Affected services
Backend API
Mobility Manager Dashboard
Employee Web App
Forms web app
Resolved
Oct 20 at 12:55pm CEST
All systems should be now up and running. Thanks for bearing with us.
Affected services
Created
Oct 20 at 09:22am CEST
Our platform is currently experiencing slowdowns and possible interruptions due to a widespread AWS infrastructure outage that has been ongoing since this morning.
We are constantly monitoring the situation through official AWS channels. Our technical team is ready to restore full functionality as soon as AWS resolves the issue.
Affected services